Urdu Nederlands
English English Deutsch Deutsch Español Español Français Français Italiano Italiano Nederlands Nederlands Português Português Русский Русский Ελληνικά Ελληνικά
Login



 
Welkom bij Jumi! >> Nieuws >> Jumi verpakking 2.0 nu voor J! 1.0 ook!

Jumi aangepaste code extensies inpakken voor Joomla! 1.0 werd vandaag vrijgegeven - versie 2.0.d. Hieruit volgt de vergelijkbare pack voor Joomla! 1.5.

Het woord verpakken betekent niet alleen het feit dat alle Jumi extensies voor Joomla! 1.0 zijn distibuted als een pack hebt, maar betekent ook dat - wat belangrijker is - ze zijn ook geïnstalleerd als een geheel. Het pakket installeert zich als een component, maar in het feit dat een component, een module en een plug zijn geïnstalleerd.

De individuele extensies - of een plugin of een module of een nieuwe Jumi component - goed samen te werken tussen elkaar en kunnen delen van de aangepaste code middelen.

Omdat er veel goede aanvulling op de vorige releases is er de Jumi pak kreeg de release versienummer 2.0. We hopen dat u zult genieten!

Wat is er nieuw

Het meest apperent verandering is dat Jumi aangepaste code extensies voor Joomla 1.0 component te bevatten. Er zijn chnges in een module en plugin ook:

  • module en plugin eigen codes te voegen uit een component database tabel,
  • module en plugin nog een andere parameter - debug-modus,
  • module voegt direct geschreven code ook,
  • plugin is in staat om geneste Jumi syntax te verwerken.

Opmerkingen over achterwaartse compatibiliteit

Jumi plugin heeft volledige achterwaartse compatibiliteit met voorgaande Jumi plugin versies.

Jumi module beschikt over volledige achterwaartse compatibiliteit te behalve argumenten waarden functie.

Tot nu toe de argumenten werden inputed in een module parameter veld als dit

[Arg1] [arg2] ... [argN]

en werden teruggevonden in aangepaste php script met $ Jumi [] array.

De module parameter veld blijft, maar heeft gegroeid en veranderen van betekenis. In de module veld "geschreven Code" je kunt schrijven de hele codes (platte tekst, HTML, PHP, javascript) nu en niet alleen waarden als voorheen.

Dus als je wilt gebruiken oud php-bestanden met argumenten in de nieuwe Jumi module kun je dat doen. Schrijf gewoon op de "Code geschreven" veld dit (op zijn minst):

$ Jumi = array (arg1, arg2, ..., argN);
?>

Wat betekent de "d" in de release nummer bedoel je?

Well. Joomla! team heeft aangekondigd dat Joomla! 1.0 niet verder zal worden ontwikkeld op basis van de zomer 2009. Als reactie Jumi team, Ed en ik hebben besloten dat we niet actief de ontwikkeling van Jumi extensies voor dEAD, of op zijn minst, depreciated project. Dat betekent:

  • als een wonder niet gebeurt zullen we geen nieuwe functies in Jumi 2.0 voor Joomla! 1.0,
  • gaan we verder met onze Jumi voor Joomla! 1.0 ondersteuning via speciale Jumi draad,
  • toekomstige versies van Jumi voor Joomla! 1.0 eventuele zal alleen onderhoud die.