Urdu Nederlands
English English Deutsch Deutsch Español Español Français Français Italiano Italiano Nederlands Nederlands Português Português Русский Русский Ελληνικά Ελληνικά
Login



 
Welkom bij Jumi! >> Nieuws >> Beveiligingsversies

Er is een beveiligingsprobleem gevonden in alle Jumi 2.xx versies tot 2.0.d (voor J! 1.0), 2.0.3 en 2.1.beta2 (voor J! 1.5)

Het betreft alleen Jumi component.

Nieuwe Jumi-versies die dit probleem vastleggen werden vandaag vrijgelaten:

  • 2.0.e stabiel voor Joomla! 1.0
  • 2.0.4 stabiel voor Joomla! 1.5
  • 2.1.beta3 voor Joomla! 1.5 met andere verbeteringen ook.

Wij raden u aan om naar de nieuwe Jumi-versie te upgraden of de volgende handleiding te repareren.

Handmatige oplossing van beveiligingslek

  1. vind bestandskomponenten / com_jumi / jumi.php
  2. maak in jumi.php de volgende wijzigingen aan:

Voor Joomla! 1.5

verander lijn 11 van

$ fileid = JRequest :: getVar ('fileid');

to

$ fileid = JRequest :: getInt ('fileid');

Voor Joomla! 1.0

verander lijn 13 van

$ fileid = mosGetParam ($ _ REQUEST, 'fileid', '');

to

$ fileid = (int) mosGetParam ($ _ REQUEST, 'fileid', '');

Bedankt voor uw aandacht en dank aan Markus die ons het risico heeft aangekondigd.